Docker Installation

This page helps you to install Aurora with Docker.

Requirements

The Aurora Docker Image has the following requirements to function properly:

  • Docker >= 19

  • Docker Compose >= 1.26

Up and Running!

If you want to start in seconds you can use a docker-compose.yml like this example:

version: "3.7"
services:
aurora:
image: itsrennyman/aurora:latest
ports:
- "3000:3000"
environment:
DB_URL: postgres://aurora:[email protected]:5432/aurora
JWT_SECRET: asupersecret
DB_SSL: "false"
AURORA_EMAIL: "[email protected]"
AURORA_PASSWORD: "password"
depends_on:
- postgres
postgres:
image: postgres:12-alpine
environment:
POSTGRES_DB: aurora
POSTGRES_USER: aurora
POSTGRES_PASSWORD: aurora
volumes:
- aurora_postgres:/var/lib/postgresql/data
volumes:
aurora_postgres: